32 lines
702 B
Nix
32 lines
702 B
Nix
{ pkgs, theme, ... }:
|
|
let
|
|
zsh_autosuggest_highlight_style = if theme == "light" then "fg=180" else "fg=10";
|
|
in
|
|
{
|
|
programs.zsh = {
|
|
enable = true;
|
|
enableCompletion = true;
|
|
history.size = 10000;
|
|
|
|
autosuggestion = {
|
|
enable = true;
|
|
highlight = zsh_autosuggest_highlight_style;
|
|
};
|
|
|
|
initExtra = ''
|
|
function set_win_title(){
|
|
local TITLE=$(git config --get remote.origin.url || echo "$PWD")
|
|
echo -ne "\033]0; $(basename "$TITLE") \007"
|
|
}
|
|
|
|
precmd_functions+=(set_win_title)
|
|
|
|
function zvm_config() {
|
|
ZVM_INIT_MODE=sourcing
|
|
}
|
|
|
|
source ${pkgs.zsh-vi-mode}/share/zsh-vi-mode/zsh-vi-mode.plugin.zsh
|
|
'';
|
|
};
|
|
}
|